Hl2, Teammenu VGUI display

Hl2, Teammenu VGUI display

Postby madgernader » Fri Jan 04, 2008 11:12 pm

Hey there everyone, I've been fiddling with hl2 again and I did the teammenu tutorial that was originally made here, and now Im trying to use HL2's VGUI controls to resize the team selection menu.... It seems to work fine, I set it all up move it how I want, Hit apply and save, but as soon as I resart the mod, it gets set to some out there value that wasnt even what it was originally... Any thoughts on what I could try?

My teammenu.res file still has all the correct information in it, its just not reading it or something...
madgernader
New Blood
 
Posts: 24
Joined: Tue Nov 28, 2006 12:55 pm
Location: United States

Re: Hl2, Teammenu VGUI display

Postby Bob » Thu Jan 10, 2008 4:08 pm

Hey man, Sorry about the length of time it took to respond but i was trying to organize my notes.

If memory serves me correctly, and i think it does, You are probably editing the menu at a resolution that is too high. I would suggest you take a moment to read up on the forums or something along those lines and look around on the wiki b/c i think the editor requires the resolution to be somewhere around 1024 or so or it doesn't scale it properly. That should sort things out for you but i cant guarantee that to be the case. More information from you would be crucial to getting this properly answered.
Bob
Site Admin
 
Posts: 252
Joined: Mon Nov 20, 2006 12:24 am
Location: San Jose California

Re: Hl2, Teammenu VGUI display

Postby madgernader » Fri Jan 11, 2008 10:51 pm

Hey, its no problems man.

I also forgot to update this post, it did turn out to be my resolution, and so I dropped it down to 640x480 and now it scales correctly, except when I first load a map and it shows, it stretches far off to the right of the screen, but as soon as I change res size or switch between window/fullscreen it fixes itself, any ideas?
madgernader
New Blood
 
Posts: 24
Joined: Tue Nov 28, 2006 12:55 pm
Location: United States

Re: Hl2, Teammenu VGUI display

Postby Bob » Sat Jan 12, 2008 12:47 pm

I remember that being the way it worked for me too. It only happened once, although i haven't touched source in nearly a year so it may have learned some other intricacies. Who knows.

Good luck, hope things work themselves out.

I am of course always around helping out. Feel free to post other questions. =)
Bob
Site Admin
 
Posts: 252
Joined: Mon Nov 20, 2006 12:24 am
Location: San Jose California


Return to Game Development

Who is online

Users browsing this forum: No registered users and 2 guests

cron